Документация
ОС Аврора 5.1.6

Запуск проекта

Содержание:

Запуск приложения на эмуляторе Аврора SDK

Приложение может быть запущено как на внешнем устройстве, работающем под управлением ОС Аврора, так и в эмуляторе, который устанавливается при инсталляции Аврора SDK. Выбор, создание и удаление модели эмулятора описаны в разделе Настройка модели эмулятора.

Для запуска приложения на эмуляторе необходимо выполнить следующее:

  1. Для запуска приложения в эмуляторе проект должен быть настроен на сборку для архитектуры x86_64. На панели слева нажать кнопку kit-selector и выбрать комплект AuroraOS-x86_64.

    Экран конфигурации проекта

  2. Запустить эмулятор нажатием кнопки emulator_stopped и дождаться, пока она не примет вид emulator_running. Откроется новое окно VirtualBox , и загрузится эмулятор. Если нажать кнопку emulator_running, эмулятор остановится, и окно VirtualBox закроется.

    Кнопка запуска приложения

  3. Для запуска приложения нажать кнопку build-and-run, для отладки — кнопку build-and-debug. Чтобы кнопки стали активны, необходимо выбрать Развернуть, используя RPM-пакет в панели выбора комплектов и способов сборки.

    Приложение установится, и откроется его стартовая страница. Взаимодействовать с приложением можно с помощью мыши.

    Стартовая страница приложения

В Alt Linux приложения, скачанные ZIP-архивом, после распаковки получают некорректные права. Такие права не позволяют пользователям, отличным от владельца, читать и запускать файл. В результате приложение запускается, но вместо UI отображается белый экран. Чтобы исправить данную проблему, следует:

  • Использовать tar-архивы вместо zip-архивов для работы с приложениями.
  • Установить на файлы и директории права на чтение и выполнение для всех групп и пользователей, а не только для владельца. В результате флаги прав должны иметь вид drwx-xr-x.

Запуск приложения из IDE на мобильном устройстве

Запуск приложения на устройстве происходит так же, как и на эмуляторе, но дополнительно требуется:

  1. В основном окне Аврора IDE выбрать пункт меню Инструменты → Параметры.

    Параметры IDE

  2. Перейти на вкладку Устройства и подключить устройство.

    Новое МУ подключено

По умолчанию для мобильного устройства в поле RPM Deploy добавлен параметр --silent (тихая установка). Данный параметр можно убрать, если каждый раз при установке новой версии приложения нужно требовать подтверждения от пользователя.

Параметр silent

Примечание:

При развёртывании проекта на устройстве/эмуляторе, помимо основного пакета, ставится также и ts-devel пакет.

Если разрешить на устройстве установку основного пакета и пропустить установку ts-devel (например, нажать на любое место на экране), сценарий развёртывания прервётся.

Прерывание деплоя

Если же подтвердить установку обоих пакетов, приложение развернётся корректно.

Затем можно запускать приложение:

  1. На панели слева нажать кнопку kit-selector, выбрать комплект AuroraOS-armv7hl или AuroraOS-aarch64, выбрать устройство как таргет для запуска.

    Выбор комплекта и таргета

  2. Для запуска приложения нажать кнопку build-and-run, для отладки — кнопку build-and-debug. Чтобы кнопки стали активны, необходимо выбрать Развернуть, используя RPM-пакет в панели выбора комплектов и способов сборки.

    Приложение установится, и откроется его стартовая страница.

    Стартовая страница приложения

Тихая установка приложений

По умолчанию каждый раз при установке новой версии приложения требуется подтверждение. Режим тихой установки предоставляет пользователю Аврора SDK возможность устанавливать приложение на устройство или эмулятор во время разработки без подтверждения.

На устройстве в настройках разработчика необходимо разрешить тихую установку приложений. В приложении Настройки нужно включить режим разработчика. В разделе, посвящённом этому режиму, имеется переключатель Allow silent installation для включения/выключения режима тихой установки.

Включение режима тихой установки

Настройка локали эмулятора

По умолчанию эмулятор ОС Аврора в настоящее время запускается с настройками русской локали. Рекомендуется переключиться на английскую локаль.

Необходимо запустить Aurora IDE и выполнить следующие шаги.

Шаг 1. Открытие настроек эмулятора ОС Аврора

В главном окне Aurora IDE выбрать пункт меню Tools → Aurora OS → Emulator mode..., как показано на следующем изображении.

Пункт меню режима эмулятора

Если проект не открыт, будет отображен диалог конфигурации.

Диалог "Эмулятор не выбран"

В диалоге "Эмулятор не выбран" нажать кнопку Настроить....

Шаг 2. Запуск эмулятора ОС Аврора

Окно настроек эмулятора ОС Аврора

В отображенном диалоговом окне нажать кнопку Запустить виртуальную машину. Это запустит виртуальную машину с эмулятором ОС Аврора. Данный процесс может занять некоторое время.

Шаг 3. Запуск приложения «Настройки»

Домашний экран эмулятора ОС Аврора

Запустить приложение «Настройки» (Settings), нажав на кнопку с изображением шестеренки.

Шаг 4. Открытие экрана настройки языка

Экран настроек

Прокрутить экран настроек вниз и нажать на элемент Язык и регион, как показано на скриншоте.

Шаг 5. Выбор локали English (US)

Экран выбора локали

Выбрать элемент English (US), как показано на скриншоте.

Шаг 6. Подтверждение смены языка

Экран подтверждения смены языка

Нажать кнопку Подтвердить в правом верхнем углу экрана. Эмулятор ОС Аврора перезапустится с английской локалью.

Мы используем cookies для персонализации сайта и его более удобного использования. Вы можете запретить cookies в настройках браузера.

Пожалуйста ознакомьтесь с политикой использования файлов cookies.